Skyduino:~#
Articles
arduino, programmation, test

[Test] Shield Lcd + Keypad de DFRobot

Le contenu de cet article a été entièrement réécrit et mis à jour sur le site Carnet du Maker.

Liens vers les nouveaux articles :

N.B. Les commentaires de l’article ont été pris en compte lors de la rédaction des nouveaux articles 😉

Publicités

Discussion

18 réflexions sur “[Test] Shield Lcd + Keypad de DFRobot

  1. ça, c’est un shield sympa, y’a tout ce qu’il faut pour dialoguer et pas cher en plus

    Publié par Philippe | 5 mai 2012, 16 h 25 min
  2. Merci pour le test ! Petite question : j’ai l’arduino Uno, le shield en question… Par contre, il ne se passe rien quand j’exécute votre code…

    Une idée pour le débuggage, pour trouver d’où vient le problème (code, matériel, etc…) ???

    Publié par Arnaud | 23 juin 2012, 21 h 04 min
    • >> Petite question : j’ai l’arduino Uno, le shield en question… Par contre, il ne se passe rien quand j’exécute votre code…

      Le code est pourtant d’une simplicité déconcertante … je ne vois vraiment pas ce qui pourrait poser probléme …
      Le contraste est il bien réglé (tourner le potentiomètre aux deux extrêmes pour tester) ?

      Publié par skywodd | 23 juin 2012, 21 h 37 min
      • Oui, j’avais effectivement pensé à cela également, mais non…
        Auriez-vous un conseil pour que je teste la shield ? L’arduino (en espérant ne pas l’avoir grillé) ?

        Pour ma part, c’est pas le code qui m’inquiète le plus (je suis issu du monde la programmation), mais plus la partie électronique…. et c’est clair que c’est la simplicité de votre montage qui m’a séduit avec la shield !

        Publié par Arnaud | 23 juin 2012, 21 h 44 min
  3. @ARNAUD:
    >> Auriez-vous un conseil pour que je teste la shield ? L’arduino (en espérant ne pas l’avoir grillé) ?
    – L’écran s’allume t-il ?
    – En modifiant le contraste est ce que des carrés noir apparaissent ?
    – Est-ce qu’il s’agit de la même shield au niveau du câblage (suivre les pistes entre le lcd et le connecteur) ?
    – Est ce que l’exemple « blink » fonctionne sur la carte arduino ?

    Publié par skywodd | 23 juin 2012, 21 h 48 min
  4. Merci pour votre aide !
    – Non, l’écran ne s’allume pas
    – Non, il ne se passe rien (pas de jus dans l’écran ?)
    – Oui, ça y ressemble drôlement !
    – Oui, l’exemple Blink fonctionne (don l’Arduino est OK)

    Arnaud

    Publié par Arnaud | 23 juin 2012, 21 h 54 min
    • >> – Non, l’écran ne s’allume pas
      Bon bin faut pas chercher plus loin c’est un probléme d’alimentation.

      Si possible (au multimètre) regarder combien il y a en VSS, VDD et VO de l’écran (par rapport à la masse).
      Il doit y avoir 0v en VSS, 5v en VDD, et quelques chose entre 0v et 5v en VO.
      Si ce n’est pas le cas, soit une soudure de la carte est mauvaise, soit une piste est coupé.
      Si c’est le cas l’écran est peut être HS (dans ce cas une photo de la shield (les 2 côtés) + écran une fois l’arduino sous tension serait pas mal pour que je comprenne ce qui se passe ;))

      Publié par skywodd | 23 juin 2012, 21 h 59 min
      • Ok, merci pour les idées. Je vais pas pouvoir tester ce soir. Demain peut-être. Est-ce qu’on peut continuer d’échanger par mail (plutôt que com’) ? Si oui, vous avez mon email dans la partie admin de WP ! 🙂 Merci, je vous tiens au courant !

        Publié par Arnaud | 23 juin 2012, 22 h 16 min
  5. Hello,

    super mini-tuto ! Très clair !
    Une question: je voulais éteindre le retroeclairage en mettant le pin 10 a HIGH mais ca ne fonctionne pas… Vous avez une idée ?

    Merci !

    Publié par vlp | 7 août 2012, 12 h 45 min
    • Je n’est plus le schéma en tête mais il me semble qu’il faut envoyer LOW sur D10 pour désactiver le rétro-éclairage.

      Publié par skywodd | 7 août 2012, 15 h 29 min
      • yes ca l’eteint mais comme j’ai l’ethernet shield en dessous ca plante tout….
        Faut q je trouve dans la librairie lcd le moyen de mettre le retroeclairage sur le pin03 pae expl…

        merci pour la reponse en tt cas

        Publié par vlp | 7 août 2012, 16 h 17 min
  6. @VLP: tu ne pourras pas changer la broche dans le logiciel.
    Il faut que tu coupe la piste que va sur la broche 10 de ta shield lcd et que tu soude un fils vers une autre broche.

    Tu auras aussi des problémes si tu utilise la carte SD de l’ethernet shield (broche D4)

    Publié par skywodd | 7 août 2012, 16 h 19 min
  7. Hello,

    Pour info, si ca peut intéresser d’autres lecteurs, la soudure PIN09 – PIN10 fonctionne parfaitement ! On peut controler le retroeclairage sans risquer d’interférences avec l’ethernet.

    J’en profite pour poser une autre question:

    Qd j’alimente le tout (Arduino Ethernet + LCD shield) par USB l’affichage est nickel mais qd je l’alimente par pile (j’ai un boiter basique (4xAA)) la couleur du text est très claire voir quasi ilisible….

    D’ou celà peut venir ?

    Merci pour votre aide !!

    ++

    Publié par vlp | 10 août 2012, 15 h 38 min
  8. Bonjour,
    comment faire pour éviter les rebonds des boutons poussoirs sur ce shield?

    Publié par Dark | 14 mai 2016, 15 h 30 min

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

Skyduino devient Carnet du Maker

Le site Carnet du Maker remplace désormais le blog Skyduino pour tout ce qui touche à l'Arduino, l'informatique et au DIY.